[osg-users] osgText - shimmer...wavy

sherman wilcox wilcox.sherman at gmail.com
Tue Oct 16 06:31:49 PDT 2007


See attached.

On 10/16/07, Robert Osfield <robert.osfield at gmail.com> wrote:
> Hi Sherman,
>
> This sounds like a precision issue related to the computation of the
> text scaling - which is done in floats.
>
> Could you modify the osgfadetext example to have text they way you are
> setting it up and see if it reproduce the problem, or perhaps send a
> small .osg file that reproduces the issue and then I can have a look
> at it.  It might be that we need to have a code path in osgText for
> using double maths internally.
>
> Robert.
>
> On 10/16/07, sherman wilcox <wilcox.sherman at gmail.com> wrote:
> > I'm using osgText with the character size mode of
> > OBJECT_COORDS_WITH_MAXIMUM_SCREEN_SIZE_CAPPED_BY_FONT_HEIGHT. The text
> > is position on an ellipsoid model with ECEF coordinates. When the text
> > is smaller than the maximum font height I notice that the text is
> > somewhat wavy when I zoom in and out. Sort of shimmers. Once the text
> > has realized it's maximum size the effect is much less noticable,
> > sometimes completely gone. Could this be a floating point precision
> > issue down in the bowels of osgText? BTW, I'm using an
> > osg::MatrixTransform node to position the text.
> >
> > Any ideas?
> > _______________________________________________
> > osg-users mailing list
> > osg-users at lists.openscenegraph.org
> > http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
> >
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: example.cpp
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20071016/542472eb/attachment-0003.txt>


More information about the osg-users mailing list