[osg-users] Please test SVN version of OpenSceneGraph

Robert Osfield robert.osfield at gmail.com
Wed Oct 3 16:11:05 PDT 2007


Hi Brian,

Thanks for the clarification.

For 2.2 I think I'll just go with what we have in SVN.  In might not
work perfectly out the box under Cygwin in all combination, but at
least there is a simple workaround for cases where it doesn't.
Perhaps if greater clarity comes after 2.2 then we can roll some
changes into the Cmake build system to better compile out of the box
under Cygwin.

As for the runtime errors you're seeing, I don't think this is an OSG
bug, rather a Cygwin/OpenGL driver error of some form.

Robert.

On 10/3/07, Brian Keener <brianklistacct at alltel.net> wrote:
> Robert Osfield wrote:
> > Hi Brian,
> >
> > O.K. I'm confused now.  Your previous email it sounds like you needed to add:
> >
> >    -DWIN32 -DNOMINMAX -mnop-fun-dllimport -DOSG_LIBRARY
>
> This was actually the second email I sent.
>
> > To get things compile, but your next below sounds like you made no changes.
> >
> > On 10/3/07, Brian Keener <brianklistacct at alltel.net> wrote:
> > > Robert Osfield wrote:
> > > > Have you updated to a different version of Cygwin since you last
> > > built?
> > >
> > > Nope,
> > >
> > > Only difference is I used a straight ccmake and did not make the
> > > CMAKE_CXX_FLAG changes I had previously made and I haven't had to make
>
> This was the first email I sent which got blocked and then I inadvertently sent
> again not realizing how confusing it would be.
>
>  The above ">    -DWIN32 -DNOMINMAX -mnop-fun-dllimport -DOSG_LIBRARY"  is my
> most recent attempt at building which did build and hangs when run.
>
> > Does the SVN version of the OSG compile out of the box without any
> > changes?  Or do you have to make the above addition, if so where to?
>
>  It does not - it dies on the socket error and I add the flags:
>
>  -DWIN32 -DNOMINMAX -mnop-fun-dllimport -DOSG_LIBRARY
>
>  in ccmake to the CMAKE_CXX_FLAGS line at which point it compiles 100%.
>
>  You posted in your other response that others had built in Cygwin without
> making any changes (out of the box).  I had not seen those responses - perhaps
> it is just my setup if you have other cygwin folk getting it right.
>
>  bk
>
>
>
>



More information about the osg-users mailing list