[osg-users] OSG blocking on application exit.

Robert Osfield robert.osfield at gmail.com
Tue Oct 2 02:34:14 PDT 2007


HI Chris,

Could you try the SVN or 2.1.13 version to see if the issues you see
with osgviewerMFC are fixed as there have been a number of fixes to it
since 2.0.

Robert.

On 10/2/07, Chris Denham <c.m.denham at gmail.com> wrote:
> Hi OSGers,
> I'm a bit of a newbie to OSG, but I've been developing an application based
> on the osgviewerMFC example in OSG2.0 (built using VS2005).
> The problem that I discovered with my application (and the unmodified
> example) is that once I have loaded in a model (e.g. cow.osg or glider.osg)
> the program does not terminate properly. It seems to close, but remains as a
> process consuming CPU resource until I manually terminate it using task
> manager.
> As "a shot in the dark" I guessed the problem might be something to do with
> threads, so I added the line:
> mViewer->setThreadingModel(osgViewer::Viewer::SingleThreaded);
> just before the call to:
> mViewer->realize()
>
> This seemed to cure the problem, so just thought someone might find this
> info useful.
> Why does this problem occur?
> What have I lost by setting single threaded mode?
> And.. has it been fixed in later versions?
>
> Thanks
> Chris D.
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
>



More information about the osg-users mailing list