[osg-users] Please test SVN version of OpenSceneGraph

Robert Osfield robert.osfield at gmail.com
Mon Oct 1 07:32:10 PDT 2007


Hi Albeto,

I've follow your suggestion and for large models have not found
crashes but rather 't' only toggles once when in DrawThreadPerContext,
but if I enter SingleThreaded and CullDrawPerContext it works fine.
This is very likely related to the crashes you are seeing.

The fact you are using a .obj is just a symptom and not a cause.  The
issue most likely stems from modifying state at the same time that its
being read from at the same time.

Robert.

On 10/1/07, Alberto Luaces <aluaces at udc.es> wrote:
> El Monday 01 October 2007 16:06:32 Robert Osfield escribió:
> > Could you explain
> > a bit more specifically what you do and the type of model you load to
> > recreate the problem?
>
> Yes, I'm loading a OBJ file. After that, I'm pressing several times the 't'
> key in order to switch on and off the texturing. Then I change the threading
> mode with the 'm' key and press the 't' key several times until I get it to
> crash.
>
> Maybe some node is not marked as dynamic by default, may I do something more
> in order to get a better isolation of the bug? Maybe convert the OBJ to OSG
> and inspect the resulting file?
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>



More information about the osg-users mailing list