[osg-users] Problems with Overriding Tooltips on Windows

Jason Beverage jasonbeverage at gmail.com
Wed Oct 3 09:22:46 PDT 2007


Hi all,

I've had a long standing issue with tooltips on some Windows XP machines
that we deploy our systems to.  If the tooltip text overlaps the
OpenSceneGraph window and the OpenSceneGraph window is redrawn, the tooltip
is cut off and invisible.  I've attached a small image of the problem in our
application.  The tooltip should say "Import Geospatial Data" but because
the OpenSceneGraph window (black area) overlaps the tooltip, it is cut off.

This seems to happen on NVidia systems mostly, updating to the latest
drivers doesn't seem to help at all.  Turning off Hardware Acceleration
completely in Windows causes the tooltips to work correctly, but my
application runs terribly slow (obviously:)) without OpenGL acceleration.
It should be noted as well that this occurs in any OpenGL application I've
tried, not just OpenSceneGraph.  I was hoping someone here had the same
experience and found some workaround.

Thanks!

Jason
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20071003/d3306a0e/attachment-0002.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ToolTipProblem.jpg
Type: image/jpeg
Size: 5756 bytes
Desc: not available
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20071003/d3306a0e/attachment-0002.jpg>


More information about the osg-users mailing list