[osg-users] Please test SVN version of OpenSceneGraph

Robert Osfield robert.osfield at gmail.com
Mon Oct 1 01:07:46 PDT 2007


Hi Brian,

On 10/1/07, Brian Keener <brianklistacct at alltel.net> wrote:
> Robert Osfield wrote:
> > >
> > > #define log2(x) (log(x) / M_LOG2_E)
> > > #define log2f(x) (logf(x) / (float) M_LOG2_E)
> >
> > That looks like it might well be the proplem.  Added a if #ifndef log2
> > might be what is required around the include/osg/Math definition.
>
> That got it to compile.  I also still have to add the flags:
>
> -DWIN32 -DNOMINMAX -W -Wall -mnop-fun-dllimport -DOSG_LIBRARY

Thanks for persevering.  I've decided to introduce a
Image::computeNumberOfMipmapLevels(..) static method to replace the
use of log2 in the texture classes, and have removed log2 from the
include/osg/Math header.  Once I have a clean build I'll check in
these changes.

> to CMAKE_CXX_FLAGS - tried only using some parts but ultimately used all the
> flags and added to CMAKE_C_FLAGS too.  This change is required for some
> reason to get Tessellator to compile and ignore those GLvoid conversion
> errors but that it probably all it is doing is ignoring them and allowing
> Tessellator to compile.

Which of the above additions to the compiler flags was required to fix
the log2 errors, which the tessellator ones?

> I also had to make the change for wsock32.lib to wsock32.a in CMakeLists.txt
> in the root of the svn tree so the compile would find the correct library in
> Cygwin.
>
> I also had to make a change for osgviewerMFC in the examples/CMakelists.txt

It should be straight forward to disable this example via CMake
directives if your building under Cygwin.

> so it would not build and had to remove the references for the wxWidgets
> (that whole routine could be nicer).

What errors do you get with wxWidgets?  I presume its installed as
CMake should build the osgviewerWX example without it.

> Most of the above I think I have reported before and OSG did build an install
> but I guess still not enough thread changes in Cygwin as osgconv still hangs
> on exit and has to be killed.

Curious.  osgconv is a single threaded app, one of the ones I'd least
expect any problems.  My best guess is that there is some issue with
destruction of proxy objects that are created on loading of the
plugins.

Does running osgconv without any parameters fail?

Robert.



More information about the osg-users mailing list